Tutorial

Media in Excel senza conteggiare le celle con valore zero (0)

microsoft Excel

La funzione Media di Excel restituisce la media aritmetica di un range di valori senza però omettere dalla media quelli che sono i valori nulli, ovvero 0.

Per ovviare a questo problema possiamo ricorrere ad una formula ad hoc. In questo esempio supponiamo di voler calcolare la media, senza valori 0, dei valori presenti nel range A1:A10. La formula è la seguente: =SOMMA(A1:A10) / (CONTA.NUMERI(A1:A10) – CONTA.SE(A1:A10;0))

Alternativamente è possibile impostare una macro VBA come quella che segue:

Public Function MediaNoZero(rngIntervallo As Range, strCondizione As String)
Dim intConta As Integer
intConta = Evaluate("COUNTIF(" & rngIntervallo.Address(0, 0)& "," & Chr(34) & strCondizione & Chr(34) & ")")
If intConta > 0 Then
MediaSe = Evaluate("SUMIF(" & rngIntervallo.Address(0, 0)& "," & Chr(34) & strCondizione & Chr(34) & ")") / intConta
Else
MediaSe = 0
End If
End Function

Quindi, nella cella in cui generare la media, scrivere la seguente formula: =MediaNoZero(intervallo_celle_media;”<>0″)